Details on the TWRPS-UGL

Forum Power supplies Details on the TWRPS-UGL

  • This topic has 8 replies, 2 voices, and was last updated 2 days ago by multiblitz.
Viewing 8 reply threads
  • Author
    Posts
    • #1752
      multiblitz
      Participant

      I would like to mod it with a different raw supply…could you share the schematic please ?

       

      Thx so much…

    • #1754
      The Well Audio
      Participant

      It’s enough simple, remove rectifiers and filter (R11, R12, R13, R14, R15, C8, C9, C10, C11, C14, C15, D6, D7, D8, D9).
      Then you can connect the different raw supply to the pads of C14 or C15 (upper pad is the positive one).

    • #1756
      multiblitz
      Participant

      Thx. I did that…tried to measure the voltage before connecting it to the Drixo, slipped with the probe, got a little spark…and now we have always 26.5V…so no regulation basically…any advise on which parts to exchange (with part numbers ?)?

    • #1758
      The Well Audio
      Participant

      Difficult to say what part is broken.

      You can try replacing in the following order:
      Q3 – BCP53-16T1G
      U1 – OPA140AIDR
      Q1 – FQT7N10LTF

    • #1777
      multiblitz
      Participant

      The OPA140AIDR is not available (except chinese offers on ebay, which I dont trust)…what is an alternative ?

      All the best

    • #1785
      The Well Audio
      Participant

      The LT1677 is a pin to pin replacement although it’s more expensive.

    • #1786
      multiblitz
      Participant

      …and as well not available…sorry to bother you again…

    • #1788
      The Well Audio
      Participant

      You can use the ADA4522-1, Mouser part 584-ADA4522-1ARZ-R7.

    • #1816
      multiblitz
      Participant

      Just of other people have the same issue: It got fixed by exchanging the cheap parts, the Q1 and Q3, no need to exchange the OP-amp…2 min job…all is good now again…

Viewing 8 reply threads
  • You must be logged in to reply to this topic.